The RustDT Eclipse IDE thread


#1

I’ve decided to create just one single thread for all RustDT related announcements and discussions. I think this is cleaner than creating a new thread for each major release (also because this forum software has some support for sub-threads). Interested parties can just subscribe to this thread. (and the weird people who use Vim/Emacs can mute it :wink:)

Comments are welcome, and if you want help with a specific situation you are not sure is a bug, Stack Overflow is also a good place to post. SO questions show up in my Google Alert for “RustDT”.


#2

Minor bugfix release out, fixes an issue with debugging and Eclipse 4.5 (Mars)


#3

Note: if you are having the dialog errors “Unknown line format: END” pop up when invoking content assist, this is a known RustDT issue with more recent versions of Racer. It will be fixed in next RustDT release, in the meanwhile, a workaround is to use a slightly older version of Racer (pre 1.0.0).

Also, I’ve added clearer RustDT configuration instructions here.


#4

Thanks a lot for your work on RustDT, it’s fantastic!


#5

RustDT 0.3.0 “Candy Kingdom” is out.

The major new feature is Build Target support:

Please read the changelog:

!Note! : if you wanna run Cargo test binaries, you need to perform a tests build before attempting to create a launch configuration (or using the Built Target context menu). This because of a Cargo limitation ( https://github.com/rust-lang/cargo/issues/1924 ), which means RustDT can’t figure out the name of the test executable before it’s created. Also, if multiple executables share the same prefix (ie, testFoo-*), a similar problem happens and RustDT can’t figure out the correct executable, so be sure to delete stale ones.

Enjoy. Hope you find it… mathematical! :wink:


#6

RustDT 0.4.0 has been released:


(Dark theme support and few minor fixes and changes)


#7

@bruno_medeiros, thank you for RustDT!

How to configure Source at “Debug Configuration…” to avoid such errors while debugging:
Can’t find a source file at "/home/nick/workspace/hello_world/…/src/libcore/fmt/mod.rs"
Locate the file or edit the source lookup path to include its location.

There is no error if I choose to locate this file at “/usr/local/src/rustc/src/libcore/fmt/mod.rs”.
How to make it automatically?

I’ve added “File System Directory” = “/usr/local/src/rustc” with “Search subfolders flag” but no luck.
I’ve created symlink “/home/nick/workspace/src” => “/usr/local/src/rustc-1.4.0/src” but no luck again (error: can’t find a source file at “/usr/local/src/rustc-1.4.0/src/libcore/fmt/mod.rs”, but this file exists).


#9

Hum, strange that the symlink way didn’t work.
In any case, I’ve looked into that, and found a way. Add a “Path Mapping” from /home/nick/workspace/src to /usr/local/src/rustc-1.4.0/src.

(D:\devel\DDT\_runtime is my workspace location)

Howerver, is it /usr/local/src/rustc-1.4.0/src where you actually have the source, or is it /usr/local/src/rustc ?

Also, I’m looking to modify RustDT so that all this is performed automatically by RustDT


#10

Thank you @bruno_medeiros!

Mapping from “/home/nick/workspace/src” to “/usr/local/src/rustc-1.4.0/src” works just fine. My Windows environment works too.

I’ve tried this mapping yesterday with no luck. The issue was in the symlink from “/home/nick/workspace/src” to “/usr/local/src/rustc-1.4.0/src”. I’ve deleted this symlink and the mapping begun to work.


#11

RustDT 0.4.1 has been released.
Mostly a few minor improvements in debugging and elsewhere.


#12

A minor follow up release is out (0.4.2), fixes an important debug issue:

  • Fixed: In debug, value of some variables not displayed due to "N/A (“child of pretty printed object)” error.

#13

0.5.0 is out.


Notable new stuff is on-the-fly parsing errors and Outline/Quick-Outline (Ctrl+O) support using the Rainicorn tool.

Outline for std::result


#14

New version out: https://github.com/RustDT/RustDT/releases/tag/v0.5.1
Added support for rustfmt.


#15

New version out: https://github.com/RustDT/RustDT/releases/tag/v0.6.0
More customization support for Build Targets, experimental support for auto-check.


#16

New version out: https://github.com/RustDT/RustDT/releases/tag/v0.7.0
Support for Rust 1.12 new error format.


#17

A new version of Rainicorn is out, update to latest Rust syntax changes:

To update from RustDT just go the preferences and press “Download”. (Note that current version of RustDT won’t recognize unions yet)


#18

New release out:

Notably support for Cargo JSON message output, some UX improvements related to building.


#19

I am getting a “can’t find crate for ‘std’” error in Eclipse after updating with rustup. I also had problems running from the console, but I managed to get “cargo run” working on the console after some effort with help from the Rust thread. However, I’ve been unable to get past this error in Eclipse. The Preferences window doesn’t report any errors. I have no idea what to look for to resolve the problem.


#20

What did you configure the Rust installation directory to be in Eclipse RustDT? It has to be the path to the Rust toolchain, not to rustup, so (for Windows) it should be C:\Users\bruno\.multirust\toolchains\stable-x86_64-pc-windows-gnu, but not C:\Users\bruno\.cargo or something else. I don’t know if rustup has a different layout for toolchains in Linux/OSX, but I assume not.


#21

I currently have ~/.multirust with a symlink to ~/.rustup, which has the toolchain directory. I tried creating a ~/.multirust with the contents of ~/.rustup, but that didn’t work even after restarting Eclipse, so it’s apparently not a symlink problem.

I can’t find anyplace in Eclipse to specify this directory. The Rust Toolchain menu in the Preferences doesn’t have a place for it.