Rust-analyser failed to discover workplace - VSCode

I am new to all things Rust. I am using VS code and have installed the rust-analyser from the marketplace.
However I keep getting a message "rust-analyser failed to discover workspace".
Can anyone suggest a solution?
Thanks in advance

Hi _Max,
Without knowing more about the project you're working in, I can only share what worked for me. From what I understand, the rust-analyzer needs to find a Cargo.toml file. So, from within VSCode. File > Add Folder to Workspace. This option will bring up a dialog window to select the folder you want to add to the workspace. I added the directory which directly contained a Cargo.toml file. I am going through a Rust course so I have lots of directories from running the cargo new command and this solved my issue. I'm really new to Rust as well, but I hope this helps.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.