Code review and name bikeshedding for my new crate `owned_slice`


After receiving some much-needed assistance from this forum a few days ago, I’ve gone ahead and polished up my library which implements slices for non-contiguous built-in-types (currently just VecDeque) and also whatever custom types you want.

However before publishing it to, I wanted to ask if anybody had any comments on the code/documentation quality itself (which of course, can and will be improved as time goes on), but perhaps more importantly, the name. Additionally, perhaps somebody can find more compelling use cases for this than just VecDeque. I was going to implement it for LinkedList but I realised that doesn’t even implement Index (I guess because that’s super innefficient for linked lists)

I thought about calling it custom_slice or, as it currently stands, owned_slice. I would of used slice except it is already taken.

Here’s the code on Github. I haven’t published it yet so the docs link doesn’t work unfortunately.

Thanks very much for any suggestions!


Slices, holes … swisscheese ?