Set up Rust for VSCode


#1

How do I set up Rust for Microsfoft Visual Studio Code using the Rust (rls) extension?


#2

If I remember correctly, the Rust rls extension pretty much configures itself. Could you describe more specifically which issues are you having?


#3

Oh weird,

This is the error I am getting
image

DO you know what can be done?


#4

Did you install Rust’s (nightly) toolchain, as suggested? The extension is offering to do it for you, but it’s possibly better if you do so yourself using rustup, the official Rust tool for managing Rust’s toolchains.

Also, you need to be in a Rust project folder. You can create one using cargo.


#5

Ok so I tried to but now I got this error?
image

How come this is happening?


#6

the lack of privileges, proxy, antivirus, old installations, viruses, concurring plugins… who knows…
If you can not manage the problem by yourself may be you should look toward bundle JetBrains Pycharm Community edition + https://intellij-rust.github.io plugin (at least it is not relaying upon unstable features). Just try it! If you still insist upon vs code usage… well you should wipe out old installation (rust, multirust, racer, vs code (and related plugins)). got admin privileges, turn off antivirus and carefully step by step install - stable rust (with rustup, and check installation!) , vs code, rust plugin. after it open any existing rust project(or just create it with cargo)…plugin ask you to install racer (and nightly branch as well) after installation it configures itself and that is all…


#7

Its not being blocked my an antivirus protection mate mate. nor do I have a proxy running. I did reinstall this extension and it still doesn’t work.


#8

OK, did you check Rust installation?


#9

Checking the extension’s repo out I found that there is a fuck up so it has got nothing to do with me