Rust-analyzer failed to load workspace

My rust and rust-analyzer are both updated to the current version, idk why this problem is still showing up. How can i solve this??

Does the error still occur if you reinstall the rustc component?

rustup default stable
rustup component remove rustc
rustup component add rustc

When i tried rustup default stable is said stable-x86_64-pc-windows-msvc unchanged - (rustc does not exist).

Then i also tried rustup component remove rust is brought up an error saying

error: failure removing component 'rustc-x86_64-pc-windows-msvc', directory does not exist: 'bin/rustc.exe'

Try removing the .rustup/toolchains/stable-x86_64-pc-windows-msvc directory in your home directory and then trying to install stable rustc again.

How can i remove it through the command line??

It finally works thank youu so much​:sob::sob::heart:

Hello,same problem here. But despite doing the steps mentioned above, it didnt fix it. Any other methods I could try?

are u using any antivirus app??

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.