My rust project is not building

Hey everyone,

since a few days I'm having problems building my rust project.
When running cargo run (or cargo build) it builds my dependencies and after that cargo hangs for at least 10 minutes (then I've stopped with Ctrl + C). The last message I receive is
Building [=====================================================> ] 354/355: my_project(bin)

The interesting thing is, that I have not changed anything in my project. I was only updating rust with rustup update and after that nothing worked more. Other projects (e.g. the cargo sample) can be built and run without any errors.

I'm using the following versions on macos 10.15.6:
rustup 1.22.1 (b01adbbc3 2020-07-08)
rustc 1.46.0 (04488afe3 2020-08-24)
cargo 1.46.0 (149022b1d 2020-07-17)

On an other machine (Debian Setup) I was working with an older version - I don't know which it was - and that resulted in no problems too. Updating with rustup there produces the same behavior when trying to build or run my project.

I have also already reinstalled rust, moved the project to an other location, run cargo clean, removed the target-directory - nothing worked... Resetting the git project to the initial files, makes the build & run work.

Here is my Cargo.toml file: https://hastebin.com/vokatikade.ini

My project is relativ big - that's why I am currently not able to create a small "working" copy for you.

I really hope that anyone can help me with this, since I have to finish a project until tomorrow evening and still have a bit to do.

Thanks a lot,
Julian

Maybe it's this issue? https://github.com/rust-lang/rust/issues/76980

1 Like

Thanks for the link. The problem looks similar but they are saying that it's a linux-only problem.
I'll follow the issue and maybe this helps me.

Switched back to version 1.45.0 solved the problem - I could have thought of that earlier...

I've ran into this problem in 1.46 too. It could be this issue: