Enable rust-lld on x86_64-unknown-linux-musl

Hi

I am using a musl distro on my workstation, with RUSTFLAGS="-C target-feature=-crt-static" this works fine. The only thing I am missing is rust-lld in llvm-tools-preview on nightly.

I built the revision of the latest nightly and enabled rust-lld, copied it into path, built a hello-world using wasm-pack and tested it.

wasm

This means rust-lld could be enabled, it is working properly. Where can I request that change? At rustup or rust on github?

Best,
David

You should be able to file a PR against this file

Thanks a lot. Here is the PR https://github.com/rust-lang/rust/pull/70619.

I updated nightly and tested the wasm workflow on musl-distro: rust-lld work :+1: Currently the update as to be forced, because not all components are built.