While using trunk getting error about wasm-bindgen version only inside of workspace

I am running a Rust Leptos project that uses a CSR build (wasm on client). When this project is run standalone by running "trunk serve" it works without issue. However when I move it into a rust workspace it gives this error below. I tried installing the wasm-bindgen-cli 0.2.87 but still get same error.
Is there a way to config the project crate such that it can run trunk without this issue?

it looks like the Rust project used to create this wasm file was linked against
version of wasm-bindgen that uses a different bindgen format than this binary:

rust wasm file schema version: 0.2.87
this binary schema version: 0.2.86 (2d882c97b)

Currently the bindgen format is unstable enough that these two schema versions
must exactly match. You can accomplish this by either updating this binary or
the wasm-bindgen dependency in the Rust project.

You should be able to update the wasm-bindgen dependency with:

cargo update -p wasm-bindgen --precise 0.2.86 (2d882c97b)

don't forget to recompile your wasm file! Alternatively, you can update the
binary with:

cargo install -f wasm-bindgen-cli --version 0.2.87

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.