Disable single diagnostic in Rust-Analyzer

I have a couple targeted allows, which per https://rust-analyzer.github.io/manual.html#diagnostics R-A doesn't respect yet.

Can someone tell me how to disable a single diagnostic using the mentioned rust-analyzer.diagnostics.disabled? I tried updating my settings like this, with no luck:

	"settings":
	{
		"LSP":
		{
			"rust-analyzer":
			{
				"enabled": true,
				"diagnostics.disabled": ["incorrect-ident-case"]
			}
		}
	}

(I'm in sublime text.)

I would guess this is not the right way to set LSP settings in Sublime Text, but I've never used it. From skimming https://lsp.readthedocs.io/en/latest/, my guess is you have to do something like

"rust-analyzer": {
    "enabled": true,
    "settings": { "diagnostics": { "disabled": ["incorrect-ident-case"] } }
}

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.