Cargo issues with loading crates on Windows 7


#1

I’ve just been getting into the Rust language, and I’ve been working through the Rust tutorial book. I’m trying to follow through the guessing game tutorial, but after updating the TOML file with the rand dependency, I’m getting errors each time I run cargo build. I’m running Windows 7, and the error recommended ensuring that TLS 1.1 and 1.2 were enabled. I’ve confirmed that the proper update and registry entries are installed, but I’m still getting the error, a screenshot of which I have attached:

error

Any help is much appreciated!


#2

Try using the latest nightly. If you’re using rustup, you can do this: rustup default nightly.


#3

Thanks! So ran that command, but I’m still getting the error, though the error looks a little different (missing the stuff about TLS).

error2


#4

I think this might be a bug. See https://github.com/rust-lang/cargo/issues/5066 . Can you run cargo -V just to make sure you’re running the latest version?


#5

It’s reporting version 1.26.0-nightly, from 2018-03-16.

I’ve had a slight read over the thread already, although I might take a closer look.


#6

I believe I fixed it! I followed nairware’s post from the github thread:

For others to emulate, my registry keys (created in each of the two directories) have the following values:

Name = DefaultSecureProtocols
Type = REG_DWORD
Data = 0x00000800 (2048)