Cannot enable proc-macro expansion for rust-analyzer in VS Code

I'm having issues enabling proc-macro expansion for rust-analyzer in VS Code. I've tried setting "rust-analyzer.procMacro.enable": true in both my User and Workspace settings, but I still get the unresolved-proc-macro lint in the editor. Is there something else that has to be enabled or installed to turn this on? The User Manual doesn't mention anything else. It does say "can also indicate project setup problems" but doesn't indicate what those might be.

This might be another instance of an issue with proc-macro-hack, which affects multiple macro-providing crates. Not sure if there's any workaround.

Thanks for the info, but I don't think my issue is related. I'm can't get any macros to expand, including the derive macros from serde and structopt and the function-like macro from lazy_regex.

Are there any specific toolchain components that are required for proc-macro expansion that I might be missing?

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.