Why you do dis xargo? [solved]


#1

So I am starting work on cirs and just defined my target spec. It works fine and dandy on my local machine but fails on travis. the log is here… https://travis-ci.org/cirs/cirs/builds/321633468 I can figure out why it happens… the target file is there but it seems like it doesnt want to pick up…

Any suggestions on how to fix this? Thanks :slight_smile:

edit forgot to link travis :confused: fixed


#2

Does anything change if you put the script in the repository’s root directory vs in a subfolder?


#3

it started failing when with this change… https://github.com/cirs/cirs/commit/3d9e7e667fead0096e1789430d9a558a1e4d15ec so I am assuming i messed the arguments somewhere, although i took x86_64-unknown-linux-gnu and adapted it for my use.

as per the subdirectory script, same it should work since it works locally as is

Also it seems I just can’t take a url and copy paste… derp


#4

right now the error seems different but no compiled result https://github.com/cirs/cirs/commit/84e84c2e47d2d551ab979befdc22bbae056d0ff8
https://travis-ci.org/cirs/cirs/builds/322005308


#5

Hmm. Try giving your bash script a .sh extension, or otherwise giving it any other name at all than its current one. I suspect that having it named as x86_64-unknown-linux-cirs is confusing Xargo and causing it to try loading the script file instead of the actual target spec file.


#6

I managed to replicate it locally and yes indeed in a clean environment, appending a .sh seems to be fix it. Thanks :slight_smile:


#7

Yet again I seem to have gotten to square 1 https://travis-ci.org/cirs/cirs/builds/322038812 :’(


#8

I would try the combination of the script having a .sh extension and also being in the root directory where the .json file is, since I’m pretty sure that the target spec file has to be in the same directory that you invoke Xargo in for it to be happy.

Alternatively, I imagine you could have Travis simply invoke the xargo build and test commands directly instead of going through a separate script at all.


#9

Apparently it was a bug in the latest nightly as pwd is now no longer used instead a env variable is used. @japaric has fixed it in xargo. Thanks for help though :slight_smile: