Vscode-rust (The extension for Rust for Visual Studio Code)


I am not native speaker and I thought that integration means ability to use.


Me neither. I would have said support.
Maybe someone else could comment on that?


I’m also not a native speaker but I understand it the same way as @KalitaAlexey, i.e. integration with RLS doesn’t mean that it is actually included.


How would you express it, when RLS comes with the extension?


I think there’s a fine distinction between “provides RLS integration” and “RLS is integrated”.
If RLS comes with the extension, I’d probably say its bundled or included.


A thought for one other future feature to think about, add in a performance profiler.



Please review issues.
Write comments.
Open a new one if you want something else.
I am going to publish a new version in four days.


0.3.12 is available


Do not update yet.


0.3.13 has been published.


I’m really trying to use vscode-rust but really struggling. I want to use RLS. I need more of a step-by-step instruction. Here’s what I tried.

Install vscode. Fine
Install the extension (version 0.3.14). Fine
It tried to “install” RLS and update rustup but there was an error. After some reading I thought that it looks like I need to have “nightly” rust installed instead of “stable”. Is this true?
I used rustup to install the nightly build.
Then the error message went away, but linting does not appear to work. Lot’s more digging, but nothing seems to work. Finally I guess that I need to install RLS ??? So I use git-clone to install it. No change
I think maybe I need to point the extension at RLS, but I don’t know how to do that…



Glad to see work continues on this!

Regarding RLS, have you tried these instructions?

That did it for me.


Thanks @mczarnek, much appreciated. Now I get “RLS started” but it doesn’t seem to run lint at all… what am I missing? While I’m begging for help, how do I run the debugger. Thanks again!.. and in advance.


OK, I think I’m starting to see how to use RLS finally. The main learning was that the “Rust Language Server” selection in the View -> Output pane doesn’t become available until you save (?). Even then I don’t always see the RLS selection, so I’m guessing I need to do more to activate it. For example the vscode-rust docs suggest adding:

“rust.rls”: {

“env”: {
“RUST_LOG”: “rls=debug”

But I don’t know where to put that… I tried putting it in settings.json, but I get a lot of errors. Please help.

Also any other suggestions on how to best use the debugger or Cargo via vscode would be appreciated as well


If you see “RLS: Started”, then it is started.
If you have an error in your code, but it does not highlight it, I would suggest you to look at the “Rust Language Server” and “Rust Logging” output channels.
After that open an issue. It must show diagnostics.


The new version has been published. 0.4.0


I am using https://marketplace.visualstudio.com/items?itemName=rust-lang.rust which is published by the rust-tools team. So, is this(vscode-rust) extension deprecated? and how this extension compares to official extension?



I’m seeing RLS crash every time I bring up vscode:

thread ‘main’ panicked at ‘No root path’, /checkout/src/libcore/option.rs:819:4

I’m seeing this in the “rust logging” output:

DEBUG: RlsMode: start: enter
DEBUG: RlsMode: start: no RLS executable
DEBUG: RlsMode: start: processPossibleSetButMissingUserToolchain: toolchainKind=nightly toolchain
DEBUG: RlsMode: start: processPossibleSetButMissingUserToolchain: user nightly toolchain is installed
DEBUG: RlsMode: processPossiblyMissingRlsComponents: RLS is installed
DEBUG: RlsMode: processPossiblyMissingRlsComponents: rust-analysis is installed
DEBUG: RlsMode: start: User decided to use rustfmt
DEBUG: RlsMode: start: rlsPath=rustup
DEBUG: RlsMode: start: env={“RUST_SRC_PATH”:"/home/joe/.rustup/toolchains/nightly-x86_64-unknown-linux-gnu/lib/rustlib/src/rust/src"}
DEBUG: RlsMode: start: args=[“run”,“nightly-x86_64-unknown-linux-gnu”,“rls”]
DEBUG: RlsMode: start: revealOutputChannelOn=3
DEBUG: RlsMode: start: Language Client Manager: start

I’m running vscode 1.15 on Linux with 0.4.2 of rust-vscode extension. Just to be clear I’m using rustup as instructed above:

rustup default nightly
rustup update nightly
rustup component add rls
rustup component add rust-analysis
rustup component add rust-src

so shouldn’t have to configure RLS executable… right?

Thanks for any help.

Update: after doing some looking on github I believe my problem is the same as https://github.com/rust-lang-nursery/rls-vscode/issues/67 which was closed on June 28 with the comment that RLS would be fixed “soon”. Any update on this?


Still getting the exact same behavior with the latest version of VSCODE.

Still struggling with this. It now appears that

rustup component add rls no longer works. I tried:

rustup component add rls-preview

Which seems to be there, but I get the same bahavior I noted above. Any help?