VSCode breakpoints skipped when including rayon prelude

Hi all/any, I have a more complex program that I'm trying to debug, but strangely none of my breakpoints work when I include the rayon prelude. Commenting out the prelude causes the breakpoint to work as normal.

I recreated the problem in a fresh, simple crate and still get the same error. I'm using rayon 1.5.0

use rayon::prelude::*; // <-- comment this line in/out to test

fn main() {
    println!("hi"); // <-- breakpoint here fails
}

Steps taken to resolve:

  • try rust stable vs rust nightly - both fail
  • use rust-lldb from command-line - breakpoints set there work, so the problem is vscode specific (?)
  • Windows works fine, problem only exists on Linux

vscode extensions i'm using:

  • rust-analyzer (0.2.574) by matklad
  • CodeLLDB (1.6.2) by Vadim Chugunov

I'm a bit of a Rust noob. Any ideas about where to go from here? Is it appropriate for me to post my problem in each of the respective forums/bug sections of the related components?