Using RLS with experimental features


#1

I have a project using inclusive range syntax. (for i in a ..= b). It compiles fine on nightly, but when running from within VSCode, RLS flags it as an error. (“inclusive range syntax is experimental”).

Is there a way to tell RLS to use the nightly channel, so that I can use it with experimental features?

Installed versions:

  • rust: rustc 1.25.0 (84203cac6 2018-03-25)
  • rust nightly: rustc 1.27.0-nightly (686d0ae13 2018-04-27)
  • rls: rls-preview 0.125.1-stable (cebf188 2018-03-19)
  • rls nightly: rls-preview 0.126.0-nightly (9144e22 2018-04-23)
  • rls-vscode: 0.4.1

#2

vscode settings
"rust-client.channel": "nightly"


#3

Today I Learned:

Oh thankyou everyone who made this! While I understood the rationale for the other behaviour, it still drove me nuts.


#4

Thanks, looks like that works! (Although it seems to require restarting vscode to apply the setting.)

I also found that it’ll end up using the default rustup channel if you don’t provide a setting.