Ubuntu 20.04 64b rustup libs not found, held broken packages

on ubuntu 20.04 64b,
I followed the basic steps of installing Rust re the online book; it had me install via
sudo curl --proto '=https' --tlsv1.2 https://sh.rustup.rs -sSf | sh
and I got a successful install of
/home/bbb/.rustup/toolchains/stable-x86_64-unknown-linux-gnu/lib/rustlib/x86_64-unknown-linux-gnu/lib
but the compile/link of hello yields some libs not found, e.g.,
/usr/bin/ld: cannot find Scrt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory

What in ubuntu 20.04 64b might be conflicting?
I'd uninstalled, reinstalled, followed every correction I could find including the aptitude and synaptic-pkexec, all leave me with held broken packages that dpkg cannot see.

I'll try a few suggestions I've just found here from 5yr ago, but in the end my question remains, ought not the doc be corrected, or the sh.rustup.rs to ubuntu 20.04 64b be fully installing? Thus my thoughts of a conflict on my system.

Do you have the build-essential package installed on your ubuntu system?

I do not, and when I attempt to, I get the error "you have held broken packages". I try to find these to remove them but am having no luck. I've tried steps listed in this forum, on itsfoss, etc., all come back as though no broken packages exist, then if I try to install build-essentials I get the held broken packages error again.

I'd not seen the 'broken package' error until I tried this Rust install.

Is build-essential in the dependency of the Rust install?

I've searched for as many fix-broken solutions, have tried them all, and none has corrected or revealed the broken packages. I just want to install Rust, and am out of options.
Is there a system log or other breadcrumb to look for as a hint?
thank you for any options you might offer.

build-essential isn't specifically required, but it pulls in a bunch of packages generally useful for development, including packages rust needs to build. It looks like those files from your error message are actually in libc6-dev, but it might not be the only thing you're missing, assuming it even installs on your system.

Even when run with sudo, the rustup tool will not affect apt state. At worst, it'll install Rust to the wrong place (usually /home/YOU/.rustup but with the wrong permissions, sometimes to /root/.rustup, unless you're setting specific env vars). If something is busted in your Apt state, it's not busted specifically because of rustup, although I would bet rustup shone some light on the problem.

You may be able to sort Apt out with a combination of sudo apt-get update and sudo apt-get autoremove, but beware that if your Apt state is particularly broken, this might make it worse, and beware that this will remove the packages that are misinstalled, which may break any non-packaged software that depends on them. An Ubuntu or Debian forum can probably help further with the sysadmin side, and whatever you do, now would be a great time to test that your backups actually work.

my install (from Rust install site) shows a dependency on libc-dev, but not on libc6-dev
doing apt show libc-dev gives a note that it is a purely virtual library with no versions

it installs under my home path, just looking for a way to discover what is not allowing the hello compile/link