Trouble using Picos with rust-dap and openocd

Hey, I tried to follow https://reltech.substack.com/p/getting-started-with-rust-on-a-raspberry-a88 and it works fine for debugging.
However, trying to add RTT to it like this:

(gdb) monitor rp2040.core0 rtt setup 0x2003fbc0 0x30 "SEGGER RTT"
(gdb) monitor rtt start
rtt: Searching for control block 'SEGGER RTT'
rtt: Control block found at 0x2003fbc0
(gdb) monitor rtt server start 3334 0
Listening on port 3334 for rtt connections

I've also tried without rp2040.core0.
I'm not getting anything with
nc localhost 3334 | defmt-print -e target/thumbv6m-none-eabi/debug/rp2040-radio
https://ferrous-systems.com/blog/gdb-and-defmt/#defmt-print
But when I run it, I get:

Info : Listening on port 3334 for rtt connections
Info : accepting 'rtt' connection on tcp/3334

Any ideas? I've been looking around for a solution over the weekend but come up empty.

Got logging with semi-hosting to work, but if anyone knows a template or what to search for to get RTT working, I'd appreciate it greatly!

I eventually got RTT logging to work alongside GDB debugging with the rtt-target and panic-rtt-target crates on RP2040 (recommendation from Rust discord channel user). Used a combination of OpenOCD, VScode's cortex-debug extension, and rust-dap (also recommended by the same user).

Not entirely sure why it started working for me. If anyone is curious to try and reproduce this, I'd be happy to throw together a template repo.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.