Tokio-postgres = "0.3.0" as dependency introduces error failed to resolve: use of undeclared type or module `ConnectError`

Introducing tokio-postgres as dependency generates error while compiling :-

error[E0433]: failed to resolve: use of undeclared type or module ConnectError
–> C:\Users\Spark.cargo\registry\src\github.com-1ecc6299db9ec823\tokio-postgres-0.3.0\src\stream.rs:50:21
|
50 | Err(ConnectError::ConnectParams(
| ^^^^^^^^^^^^ use of undeclared type or module ConnectError

That is behind a #[cfg(not(unix)] block. Skimming it I don’t see any way for a ConnectError to be imported, so it seems likely that the code is just broken on Windows. Testing with cargo build --target x86_64-pc-windows-gnu I get the same error.

It’s probably worth opening an issue on the repo, it would be good for them to setup cross-platform testing if they’re going to have platform-specific code blocks.