Sqlx not recognizing lib folder path and dies

Windows 10

I am new to rust and I'm trying to set up a path to a cargo build.
I do not know how to get a folder into the path itself.

It can not find the postgres libs, so it dies.

I have tried copying the files then doing the cargo build, but that didn't work. (after a restart of CMD)

Okay your question has no details at all. I can't tell what you're trying to do.

You need to explain the file/folder hierarchy, show us what error you're getting, and most importantly post a minimum reproducible version of the code that fails.

error: linking with link.exe failed: exit code: 1181
error: aborting due to previous error
error: could not compile migrations_macros.
= note: LINK: fatal error LNK1181: cannot open input file 'libpq.lib'

It is because I don't know how to make a path of the lib folder connect to the cmd

Do you have postgres installed?

Yes

Do you have a short sample of code that fails? I just tried compiling a sqlx sample without postgresql installed but postgres feature enabled and it compiled file. Is this a runtime error?

No unfortunately