Rustup installation curl certificate error

I am using puppylinux on raspi.
Can someone help with rustup installation error raised by curl certificate from its script file. Using the -k option from command line downloads the script file but there is curl code inside the script file as well.
How to bypass the ssl verification for that file?
This SO answer gives a solution to global insecure curl, but where should I inject that one line of code?

What exact error do you get?

The bash script tries to detect which OS and cpu architecture you use and then download the right rustup-init executable. You can download it directly from Other installation methods - The rustup book to bypass the curl invocation in the bash script.

The certificate error likely means that you don't have a ca-certificates package installed on the OS, or it's too old. Try installing OS updates.

It may also mean that you have some kind of network sniffer (maybe an antivirus, or "child safety" proxy filter) intercepting your connections.


curl -k --proto '=https' --tlsv1.2 -sSf | sh

info: downloading installer
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: curl - SSL CA Certificates

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

@bjorn3, I had downloaded the init file previously but then there was no way how to execute that file? Can you help me with what to do next with the file? How to execute this init file?

@kornel I have installed the new ca certificate and put it at /etc/ssl/certs, still curl is not getting it.

You have to make the file executable using chmod +x /path/to/rustup-init.

@bjorn3 yes I had done that as well but clicking it didn't do anything. Do I have to pass some command for it to execute?

You should run it from a terminal. It doesn't gave a gui, but a tui.

Thanks @bjorn3
Installed rustup. Had almost given up on rust.
Thanks once again...

@bjorn3 need some more help. As now rust is installed, I wanted to install nightly toolchain as it is required by a package (polars). Still, have no clue as to why a package is built with nightly instead of stable. I have just started rust, so may be missing something behind usage of nightly for a distribution package.
Here is the problem. I am using the command

rustup toolchain install nightly

and getting network error

> info: syncing channel updates for 'nightly-armv7-unknown-linux-gnueabihf'
error: could not download file from '' to '/root/.rustup/tmp/6_tjfa8_sjm_e_6c_file': failed to make network request: error sending request for url ( error trying to connect: dns error: failed to lookup address information: Temporary failure in name resolution: error trying to connect: dns error: failed to lookup address information: Temporary failure in name resolution: dns error: failed to lookup address information: Temporary failure in name resolution: failed to lookup address information: Temporary failure in name resolution

Have successfully pinged from terminal.

Have also downloaded the channel-rust-nightly.toml from browser.

rustup update is also giving the same network problem.

Can you help me with this as well?

Weird. Dns lookup should work if ping for the same domain works.

So, should I create a new topic for this problem?

Do you have a man in the middle or something that you needed to disable tls certificate verification when using curl?

No, but in my problem statement I have given a link to a SO answer which disables the curl ssl verification globally, but had no idea as to where that line of code needs to be inserted.

Does cargo uses curl as well, for installations/updates? If so, it should have given the error of certificate.

I believe it uses curl by default. In this case however the error occurs during dns lookup, which is way before any certificate errors could occur.

Ok. Have started a new topic for this problem.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.