[rustls] in 0.22 how to migrate `AllowAnyAuthenticatedClient` usage

Hi,

I’ve search around rustls repo and on the web, but I can’t find anything about how to migrate the usage of AllowAnyAuthenticatedClient which has been removed in version 0.22 of rustls.

Does anyone has a clue about it?

Looking at the documentation for WebPkiClientVerifier, it looks like the equivalent is WebPkiClientVerifier::builder(roots.into()).build().unwrap().

1 Like

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.