"rustc: error while loading shared libraries" after "rustup update"

Rust has worked great till today when I 'rustup update'. After that I get
~> rustc -vV
~/.rustup/toolchains/stable-x86_64-unknown-linux-gnu/bin/rustc: error while loading shared libraries: libLLVM-15-rust-1.66.0-stable.so: cannot enable executable stack as shared object requires: Permission denied

I've read different threads about updating LD_LIBRARY_PATH and tried unistall/reinstall, but nothing works for me. I can not find libLLVM-15-rust-1.66.0.stable.so on my machine. If the intention is that rustup shall install that somewhere, it might fail due to that I'm using OpenSUSE MicroOS? On the other hand, it has worked fine since I installed it first time.

~> uname -a
Linux localhost.localdomain 6.1.3-1-default #1 SMP PREEMPT_DYNAMIC Wed Jan 4 11:03:53 UTC 2023 (a5315fb) x86_64 x86_64 x86_64 GNU/Linux
~> cat /etc/os-release
NAME="openSUSE MicroOS"


ID_LIKE="suse opensuse opensuse-tumbleweed"

Any suggestions appreciated.
What versions should I use if I should try 'rustup install ???' and/or 'rustup default ???' ?

Did you at some point run rustup as another user ? Via sudo or such ?

Hmm... not sure if I've done that earlier.
For sure I have done that now during my trials. As user and as root. There is only one user on the computer.

I've tried to install rustup via the system, and removed it again. As root:
transactional-update pkg install rustup && reboot
rustup toolchain install stable
(same issues)
transactional-update pkg rm rustup && reboot

As user:
rustup self uninstall
curl --proto '=https' --tlsv1.2 -sSf https://sh.rustup.rs | sh
(same issues)

Looks like it is related to my installation of MicroOS somehow. I've worked around by creating a separate distrobox installation. Closing this question.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.