RustByExample.com is down?


#1

Well, I found the answer myself before posting, so I’ll post the answer for posterity.

Rust By Example is now at https://doc.rust-lang.org/rust-by-example/

Mentioned in https://blog.rust-lang.org/2018/03/29/Rust-1.25.html

Currently, rustbyexample.com is failing to resolve, but I assume it will be changed to redirect to the new site soon.


#2

Sigh, thanks. I was going to check this this morning; i tried to redirect, but maybe it didn’t work. I’m pretty terrible at DNS…


#3

Don’t get frustrated, Steve! We love you nevertheless! :heart:


#4

An update: I haven’t seen it properly resolve yet, but the support person i talked to said it’s working on their end, so I guess it’s down to DNS propagation at this point.


#5

Thanks a lot for this post! :heart:

I was slowly going insane because downforeveryoneorjustme said “It’s just you.”.


#6

The DNS appears to be resolving correctly now, but Firefox and Chromium both hang on "Performing a TLS handshake to rustbyexample.com..." and finally time out. This happens regardless of typing http: or https:.

It works with curl with http but not https.


#7

Hey guys, just throwing in another anecdote, been unable to open it still!

Please let me know if I can help!

Meanwhile, for anyone who absolutely needs it,

rustup docs

And then follow the link to Rust By Example.


#8

This is very strange; I can see it as “up” on my phone, but “down” on my computer. Tons of people are seeing it up, some down.

I have no idea what’s going on…


#9

I can ping it, but I can’t pull it up in Firefox.

I can, however, pull it up in lynx.


#10

I cannot open it in firefox, but ping and curl.

With curl I get

<a href='https://doc.rust-lang.org/stable/rust-by-example/'>Found</a>.

#11

@steveklabnik, there’s an HTTP server doing redirects on 80, but nothing listening for HTTPS or 443. (Or at least nothing responding.) The problem with that is that rustbyexample.com is in the HSTS preload list, so Chrome & Firefox will only try connecting on HTTPS.

Although, I’m not sure why it’s working on your phone…


#12

Okay so, I’ve decided that rather than use my host’s apparently terribly broken redirect feature, I’ve pushed a tiny index that will do the redirect, and i’ve pointed the domain back at gh-pages. Sorry again, everyone, hopefully this takes care of it.


#13

So i learned something new today; HSTS prevents me from manually creating HTTPS exceptions for websites.

I get the following error at the moment for rustbyexample.com
Error code: SSL_ERROR_BAD_CERT_DOMAIN
Looks like the server provided a wildcard certificate for github.com.
Will this fix itself within the next hours?


#14

Unfortunately it won’t fix itself because GitHub Pages doesn’t support TLS with custom domains. https://github.com/isaacs/github/issues/156

A workaround is to put Cloudflare in front of it: https://blog.cloudflare.com/secure-and-fast-github-pages-with-cloudflare/

There are other ways, like not using GH pages, but those other solutions probably cost money.


#15

Sigh. Thanks both of you; I forgot about this for Reasons. I’ll get on CloudFlare soon.


#16

Glad people are on this. :slight_smile:
Security is an annoyingly good thing.


#17

Hey all! Sorry again about the delay here, RBE should be back up now.


#18

Not convinced I’m afraid. From here it looks like no DNS records for that domain.


#19

Hmm, very odd. It worked yesterday… I’ll investigate.


#20

GH pages recently introduced TLS with custom domains, by the way. https://blog.github.com/2018-05-01-github-pages-custom-domains-https/ . You may no longer need an external service.