Rust-analyzer setup with neovim/astrovim not working

I tried to install the rust-analyzer for astrovim through the command :LspInstall rust and the installation failed with the error message:

Downloading file ""...
      ...acker\start\mason.nvim/lua\mason-core\installer\init.lua:113:\start\mason.nvim/lua\mason-core\managers\std\init.lua:93: Unable to unpack rust-analyzer.exe.gz.

When I type LspInfo, I get:

 Language client log: C:\Users\notna\AppData\Local\Temp\nvim\lsp.log
 Detected filetype:   rust
 0 client(s) attached to this buffer: 
 Configured servers list: sumneko_lua

I tried installing the rust-analyzer manually and I've addet it to PATH and I've also tried CocInstall but nothing works.
I'm on Windows 10.
Any help appreciated

that error shows you don't have unpsckers for .gz files.

if you're on Windows use Visual Studio Code instead.

how/where do I install gz unpackers? I tried WinZip but that doesn't seem to work.

1 Like

If anyone found this post through a search. To fix your problem try to install 7z and put into PATH environmet 7z.exe file location

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.