Rust-analyzer errors with FetchWorkspaceError in VSCode not sure how to fix this error

Hi, need some help figuring out how to fix this Rust-Analyzer error. For simplicity I am starting with an empty project using cargo new learn_rust.

I am getting the following error:

[ERROR rust_analyzer::main_loop] FetchWorkspaceError:
exited with an error: error: none of the selected packages contains these features: ssr

and Cargo.toml looks like this.

[package]
name = "learn_rust"
version = "0.1.0"
edition = "2021"

# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html

[dependencies]

I am wondering why it is asking for an ssr feature which doesn't exist in this project.

Sorry, I just found the problem.

I added the following to my config some time ago, to get Rust-Analyzer to recognize ssr as a Cargo feature. Apparently this results in it not working for every other project that does not use it. Deleting it solved the problem.

    "rust-analyzer.cargo.features": [
        "ssr"
    ],