RA VSCode F2 not working

F2 has stopped working in one of my projects. If I copy the code into a new file it works fine, so it seems like the problem is with my project (maybe too large or complicated?) rather than some syntax problem in the actual file.
I'm trying to work through the trouble shooting section here User Manual but I'm stuck. The instructions say to update RA if the version is more than a week old but VSCode returns "rust-analyzer version: 0.3.1203-standalone" as the version which doesn't mean anything to me and doesn't correspond to any of the release names on Github. I figured I would just update RA anyway but I can't work out how to do this and my understanding is that VSCode does it automatically anyway. Should I do rustup components remove rust-analyzer-x86_64-unknown-linux-gnu followed by rustup components add rust-analyzer-x86_64-unknown-linux-gnu? I'm on Ubuntu 20.04 and have tried restarting VSCode, restarting RA from the VSCode menu, and deleting Cargo.lock and /target.

I tried deleting my project and cloning a fresh copy, and this did not solve the issue. Is what did solve the issue however was simply renaming the directory of my project. To me it seems like there is some data being cached somewhere that is tied to the name of the project directory, but I don't understand RA or how it interacts with VSCode well enough to further debug this in order to create a simple reproducible example I can file in a bug report. Any help or guidance would be appreciated. Note I had the same problem in Lapce as VSCode so it seems like the problem is definitely with RA rather than the editor.