Problem with setting python extensions in vscode

I had written earlier, but didn't find how to fix this, i've tried to build in TOML cpython and PyO3:
1)cpython
Compiling cpython v0.6.0
error[E0425]: cannot find value PYTHONSYS_ENV_VAR in this scope C:\Users\2020.cargo\registry\src\github.com-1ecc6299db9ec823\cpython-0.6.0\build.rs:28:32
|
28 | let flags = match env::var(PYTHONSYS_ENV_VAR) {
| ^^^^^^^^^^^^^^^^^ not found in this scope

error[E0425]: cannot find value PYTHONSYS_ENV_VAR in this scope
--> C:\Users\2020.cargo\registry\src\github.com-1ecc6299db9ec823\cpython-0.6.0\build.rs:37:17
|
37 | PYTHONSYS_ENV_VAR
| ^^^^^^^^^^^^^^^^^ not found in this scope
2)PyO3: Compiling pyo3 v0.13.2
error: failed to run custom build command for pyo3 v0.13.2

Caused by:
process didn't exit successfully: C:\Users\2020\RUSTprojects\trburcor\target\debug\build\pyo3-8786ed9dcaa55a08\build-script-build (exit code: 1)
--- stderr
Error: "Python 3.x interpreter not found"
The terminal process "C:\WINDOWS\System32\cmd.exe /d /c cargo build" terminated with exit code: 101.
These errors from vscode, what i've tried:
Created Py environment and run in terminal pypyint-env\Scripts\activate.bat
Then this work, but only in terminal.
Further I enter ctrl+shift+p -> python env-> choose one. Still error.
Tried in setting.json indicate path to py interpreter.Still error.
Cpython also as above you see...

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.