Problem with 'rustup update stable' on win7-64 virtualbox

For a couple of years now I've had a Windows 7 64-bit VirtualBox that I keep up-to-date using 'rustup update stable'. This worked fine up to 1.58.1. But fails with 1.59.0 with "error: failed to install component: 'rust-docs-x86_64-pc-windows-msvc', detected conflict: 'lib/rustlib\manifest-rust-docs-x86_64-pc-windows-msvc'".

I also tried with 'rustup update --force stable', but got the same error.

Next I tried to get back to where I was with 'rustup update --force 1.58.1'. Once I followed this by 'rustup default 1.58.1' everything was back to normal and worked.

But, of course, I still don't know how to go forward to 1.59.0.

Looks like this rustup issue: Corrupt /missing manifests lead to installation conflicts · Issue #2417 · rust-lang/rustup · GitHub

The solution is to remove the entire toolchain and reinstall it with all the desired components. There is no need to uninstall all of rustup, but there is also no lesser solution.

Thank you. I tried just installing the toolchains but it didn't work. So instead I did 'rustup self uninstall' and then manually deleted the .rustup folder (since rustup couldn't do that) and then downloaded rustup-init.exe and that worked fine.

1 Like

You might want to leave a comment on that issue indicating that uninstalling the toolchain didn't fix the issue, to give the maintainers a fuller picture of what's going on.

OK, done.

1 Like