Problem with installing rustup-rs on Windows


#1

I’m trying to install rustup-rs on my Windows machine at work (behind a proxy) using rustup-init.exe but every time I’m getting following error:

error: could not download file from 'https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256' to 'C:\Users\oleg\.multirust\tmp\m51gbmnxzt7hj98l_file' info: caused by: http request returned failure: [35] SSL connect error

Google gives me several links to the rustup-rs issues related to proxy problems but all of them are already closed.

I had before similar problem with using git in the console but after installing native windows GitHub application it was solved (I can use git from GitHub Bash but still not from cmd). I suspect I have to register SSL key for the https://static.rust-lang.org site somehow but I don’t know how.

Can anybody help me with this?


#2

Thanks for reporting this. I don’t recall seeing an issue like this recently.

SSL connection errors to static.rust-lang.org are often because the client doesn’t support either SNI or TLS 1.2, but I haven’t seen such a failure on Windows.

You might try installing with RUSTUP_USE_HYPER set, like RUSTUP_USE_HYPER=1 ./rustup-init.exe. It probably won’t change anything.

What version of Windows are you running, and what version of rustu-init?

Do you mind filing an issue on https://github.com/rust-lang-nursery/rustup.rs/issues?


#3

After running RUSTUP_USE_HYPER=1 ./rustup-init.exe I’ve got following error message:

info: syncing channel updates for 'stable-x86_64-pc-windows-msvc' error: could not download file from 'https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256' to 'C:\Users\oleg\.multirust\tmp\cshl3tis_w_u4t2b_file info: caused by: failed to make network request info: caused by: other os error info: caused by: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. (os error -2146762487)

Looks like I have to register some certificate…

I have created an issue for this problem.