Problem when compiling and linking, when using nightlyRust toolchain with plugins for llvm. ( rsbegin.rs not a found )

Question to those who are practicing the use of rast night builds.
Trying to get the whole thing to work -> Rust obfuscation guide · eshard/obfuscator-llvm Wiki · GitHub.
I tried to build Rast nightly toolchain with additional plugin for llvm.
Did everything as described. Tried different rast versions (1.6.0 and 1.6.2).
Problem with the linking.
Please advise where to change or fix something?

Build as follows -> cargo +my-rust build -Z build-std=panic_abort,std,core,alloc,proc_macro --target x86_64-pc-windows-gnu --release

The text of the error messages is below.

error: linking with `x86_64-w64-mingw32-gcc` failed: exit status: 1
  |
  = note: "x86_64-w64-mingw32-gcc" "-fno-use-linker-plugin" "-Wl,--dynamicbase" "-Wl,--disable-auto-image-base" "-m64" "-Wl,--high-entropy-va" "rsbegin.o" "/tmp/rustc7UcR8A/symbols.o" "/root/cliws/target/x86_64-pc-windows-gnu/release/deps/cliws-749d0df4eaeace61.cliws.f5cd55b7-cgu.0.rcgu.o" 
                [some txt here]
"-lwinapi_ntdll" "-lwinapi_opengl32" "-lwinapi_secur32" "-lwinapi_user32" "-lwinapi_winspool" "-lwinapi_ws2_32" "-ladvapi32" "-luserenv" "-lkernel32" "-lws2_32" "-lbcrypt" "-lgcc_eh" "-l:libpthread.a" "-lmsvcrt" "-lmingwex" "-lmingw32" "-lgcc" "-lmsvcrt" "-luser32" "-lkernel32" "-Wl,--nxcompat" "-L" "/root/rust/build/x86_64-unknown-linux-gnu/stage1/lib/rustlib/x86_64-pc-windows-gnu/lib" "-o" "/root/cliws/target/x86_64-pc-windows-gnu/release/deps/cliws-749d0df4eaeace61.exe" "-Wl,--gc-sections" "-no-pie" "-nodefaultlibs" "rsend.o"
  = note: x86_64-w64-mingw32-gcc: error: rsbegin.o: No such file or directory
          x86_64-w64-mingw32-gcc: error: rsend.o: No such file or directory
  


Below I try to build the same code under nix target ( command -> load +my-rust build -Z build-std=panic_abort,std,core,alloc,proc_macro --target x86_64-unknown-linux-gnu --release )

error: linking with `cc` failed: exit status: 1
  |
  = note: "cc" "-m64" "/tmp/rustcjO20cd/symbols.o" "/root/cliws/target/x86_64-unknown-linux-gnu/release/deps/cliws-e9f8017701c398ea.cliws.8daea4a6-cgu.0.rcgu.o" "-Wl,--as-needed" "-L" "/root/cliws/target/x86_64-unknown-linux-gnu/release/deps" "-L" "/root/cliws/target/release/deps" "-L" "/root

(.text._ZN55_$LT$f64$u20$as$u20$compiler_builtins..float..Float$GT$4frac17h229a3a6876073ed1E+0x3): undefined reference to `core::intrinsics::const_eval_select'
          /usr/bin/ld: /root/cliws/target/x86_64-unknown-linux-gnu/release/deps/libcompiler_builtins-eb5b7753c55da9d2.rlib(compiler_builtins-eb5b7753c55da9d2.compiler_builtins.658f9b54-cgu.0.rcgu.o): in function `<f64 as compiler_builtins::float::Float>::from_parts':
          compiler_builtins.658f9b54-cgu.0:(.text._ZN55_$LT$f64$u20$as$u20$compiler_builtins..float..Float$GT$10from_parts17hb4e70e476d35aed9E+0x23): undefined reference to `core::intrinsics::const_eval_select'
          collect2: error: ld returned 1 exit status
      
  = help: some `extern` functions couldn't be found; some native libraries may need to be installed or have their path specified
  = note: use the `-l` flag to specify native libraries to link
  = note: use the `cargo:rustc-link-lib` directive to specify the native libraries to link with Cargo (see https://doc.rust-lang.org/cargo/reference/build-scripts.html#cargorustc-link-libkindname)

error: could not compile `cliws` due to previous error
cat /proc/version
Linux version 5.4.0-121-generic (buildd@lcy02-amd64-013) (gcc version 9.4.0 (Ubuntu 9.4.0-1ubuntu1~20.04.1)) #137-Ubuntu SMP Wed Jun 15 13:33:07 UTC 2022

Any help are very welcome.
Thx for attention.