Going down the bikeshed route further,
schedule is another commonly used verb for sending work to a batch system.
I’m a bit torn about changing this naming convention. On one hand, using
spawn will feel more familiar to thread users at the start. On the other hand, thread pool jobs are not OS threads, and that means that the best practices change quite a bit (avoid direct synchronization, synchronous IO, basically anything that may block the underlying OS thread). So people will need to understand the difference at some point.
Overall, I would probably tend to agree with changing the name, because being misled into thinking that two things are the same at the start and having to un-learn that incorrect impression later on is definitely a source of learning pains.