Native compilation of rustc on aarch64 segfaults


#1

I am encountering an segfault while natively compiling the rustc environment itself on an NXP LS2088 8-core A72 arm64 platform .
Using :

  • kernel 4.1.8
  • CentOS Linux release 7.2.1603 (AltArch) userland.
  • gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC)

Fault :
[root@localhost rust]# make
cfg: version 1.12.0-dev (b4e11c2af 2016-07-06)
cfg: build triple aarch64-unknown-linux-gnu
cfg: host triples aarch64-unknown-linux-gnu
cfg: target triples aarch64-unknown-linux-gnu
cfg: host for aarch64-unknown-linux-gnu is aarch64
cfg: os for aarch64-unknown-linux-gnu is unknown-linux-gnu
cfg: have good valgrind for aarch64-unknown-linux-gnu
cfg: using CC=gcc (CFG_CC)
cfg: using CXX=g++ (CFG_CXX)
cfg: disabling valgrind run-pass tests
rustc: aarch64-unknown-linux-gnu/stage0/lib/rustlib/aarch64-unknown-linux-gnu/lib/libcore
make: *** [aarch64-unknown-linux-gnu/stage0/lib/rustlib/aarch64-unknown-linux-gnu/lib/stamp.core] Segmentation fault

Could be the compiler or some ./configure option.
Just interested if this has been seen elsewhere

Thx
P/


#2

I don’t see anything on the issue tracker, could you file a bug?


#3

It looks like another crash of the buildbot cross-compiled official binaries on an actual, newer Linux system (someone tried to run rustc on an armv7 Jolla phone with the same result a while ago).

If your system’s glibc 2.23 based, you could try this aarch64 build, that I bootstrapped 2 weeks ago. If that runs fine, these issues could be related.