I’m running into an issue where there is an unexpected choice being made when resolving decencies on a crate of mine.
I am using mongo-rust-driver and it depends on which in turn depends on mongoc-sys. In mongoc-sys’s "openssl-sys = “> 0.7.0”. The rest of my project needs ~0.7. I even have this is my Cargo.toml:
openssl = "0.7.14"
openssl-sys = “0.7.17”
Looking at this I would think “Oh well, it will just use 0.7.14 because that meets the ‘> 0.7.0’ requirement,” but I would be wrong. For some reason I get the error message:
error: native library
opensslis being linked to by more than one version of the same package, but it can only be linked once; try updating or pinning your dependencies to ensure that this package only shows up once
When I run cargo-graph I see mongoc is the only crate that is using openssl-sys v0.9.1. What can I do to tell cargo to use 0.7.17 for mongoc?