Lldb on Beta 1.46 failing to start

I was playing with lldb on Rust stable, and I was looking for ways for correctly printing Rust types as the Rust plugin for Clion does.

Then I found that on Beta branch it Intellij pretty printers are incorporated into Rust source code, so I decided to test it changing my toolchain to beta with rustup.

Then I recompile my project with cargo build -v, and tried to use rust-lldb but I'm receiving this message:
error: file specified in --source (-s) option doesn't exist: './lldb_commands'

Does anybody knows is I'm missing something?

From rust source, I saw lldb_commands is inside /src/etc/ but it should get compiled with rustc?

Hi @douglascorrea, having the same issue here, I see that you wrote this many days ago. Have you figured it out???

Hi even now that 1.46 it is raising the same error :frowning:

For reference, I opened a issue: https://github.com/rust-lang/rust/issues/76006

Out of curiosity, does 1.46 work with gdb?

I didn't try, but I think the change they did was only for LLDB, if you see my issue, they are already working on a fix because it is failing on this new version.