Is RUST 1.58.x affected by apache-log4j-vulnerability

Can anyone let me know if Rust version 1.58.x package for Windows 10 is affected by CVE-2021-44228 and CVE-2021-45046) that was identified in Apache Log4j utility impacting versions, 2.0 - 2.14.1

Thanks
Prabhangshu

Um, Log4j is a Java library, not Rust.

4 Likes

The Rust compiler does not use any Java code, so it is not affected by the log4j vulnerability.

4 Likes