Installation on windows 10, toolchain problem


#1

Hi all,

I’m new to programming and would like to learn Rust, but I am stuck with installation. I installed rust 1.20.0 (through rustup) stable version and build tools. I have windows 10. I thought everything should be OK, but when I type rustc -V I get
error: override toolchain ‘1.20.0’ is not installed
info: caused by: the toolchain file at ‘\?\C:\Users\Ray\rust-toolchain’ specifies an uninstalled toolchain
I have no idea how to fix it. Do you know what might be wrong?

thank you


#2

Does it work if you tell rustup to explicitly use stable (i.e. 1.20.0)?

$ rustup default stable

#3

I tried, but it didn’t help, still the same error :-(. It works with gnu toolchain, so I thought there might some problem with rust finding msvc, but dont know how to repair it.


#4

Have you installed the msvc tools?


#5

I have. I found out, that when I launch rustc from .rustup\toolchains\stable-x86_64-pc-windows-msvc\bin> it works fine. So I dont know what is happening


#6

It sounds like at some point you did a rustup override set 1.20.0. This is different than the auto-updating stable channel, and will only work if you had also done rustup install 1.20.0 explicitly. Try rustup override unset to get back to using the default.


#7

Great, this worked. Thanks a lot!