How to skip/disable running of unittests in rustc bootstrap build testing

I am running rustc bootstrap build tests via cmd:

python3 src/bootstrap/bootstrap.py test --exclude "some excluded test cases list" --no-fail-fast --bless --target x86_64-poky-linux-gnu

which give failures as follows:

Running unittests src/lib.rs (/home/build-st/tmp/work/core2-64-poky-linux/rust/1.77.0/rustc-1.77.0-src/build

/bootstrap/debug/deps/bootstrap-fca753a60bf3f353)
uploaded "/home/build-st/tmp/work/core2-64-poky-linux/rust/1.77.0/rustc-1.77.0-src/build/bootstrap/debug/deps/bootstrap-fca753a60bf3f353", waiting for result
thread 'main' panicked at src/tools/remote-test-client/src/main.rs:310:9:
client.read_exact(&mut header) failed with failed to fill whole buffer
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace
error: test failed, to rerun pass --lib
error: test failed, to rerun pass --bin bootstrap
error: test failed, to rerun pass --bin rustc
error: test failed, to rerun pass --bin rustdoc
error: test failed, to rerun pass --bin sccache-plus-cl

error: 5 targets failed:
--lib
--bin bootstrap
--bin rustc
--bin rustdoc
--bin sccache-plus-cl

Since these unittests give build failures, how can I skip/disable(all unittest cases) them from running using the above cmd (any flag or option to be passed with cmd) so that the build is completed successfully.
Thanks.

@bjorn3, Can you assist me with this?

Actually, until rust 1.75 unittests were not executed since we were using --doc option in the cmd. But, from rust 1.76 we dropped that option as it didn't run any tests (unittest and integration tests) on cross-targets.

After this, many of the unittest cases failed as above.

  1. What can be the reason for this?
  2. As a work around, how can I disable/skip execution of all unittest cases? Is there any cmdline flag/option to do so?

I know about the #[ignore] tag but it's not feasible to do as there are many files.

Answer: Skip using --exclude tidyselftest