How to disable the auto build of rust-analyzer?

I'm learning a project which can't build on win10, but my vscode is using on win10. So when I try to open the project, rust-analyzer will use a lot CPU and a lot time to build it, but finally failed, so can I know is there a way to diable the auto build function of rust-analyzer?

You are looking for this config I think:

https://rust-analyzer.github.io/manual.html#rust-analyzer.checkOnSave.enable

thanks, i'll try it

Hi, I have the same issue, setting the aforementioned setting to false didn't help

Any more suggestions please?)

Does it run every time you save or only during the initial load of the project after you opened it in your editor? If the later, try setting rust-analyzer.cargo.runBuildScripts and rust-analyzer.procMacro.enable to false. These both build part of your dependencies once to be able to for example expand proc-macros or include files generated by build scripts.

1 Like

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.