I want to provide two variants of method for chaining.
fn set_t(&mut self, &T) -> &mut self
fn set_t(self, &T) -> self
What should I name these methods to avoid confusion? My first idea was set_t, set_t_owned
but I think the name _owned
might be confused with parameter(T
).