How do I force stable rust use for rust-analyzer in vscode?

I use a library which forces me to default nightly, but this is making rust-analyzer unstable. I need to stop and restart vscode constantly to get rid of errors on screen after editing.

1 Like

How about making the global setting be stable Rust, but add an override for the directory with the library?

I'm told on Reddit that the stable/nightly makes no difference, but rather it was a problem with rust-analyzer which has now been fixed in the latest version.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.