Hi. Trying to get "hello_rust" to compile

The error comes from Visual Studio’s link.exe not recognizing an argument. Perhaps your Visual Studio version is too old?

I have 2017, which should be good. I think I have the c++ tool installed. but I thought we could still run Rust source code without it.

VS2017 should be fine. The “/largeaddressaware” flag appears to be for 32-bit executables only. Perhaps if you compile for 64-bit instead (which may be a good idea anyway), the problem will go away?

I just installed VS-2019 and the C++ tools. It works now. thanks.

1 Like