Gitlab CI Error (Cargo.toml)

Hello,

I am trying to configure Gitlab's CI for my template project for new Warp servers: https://gitlab.com/Kozaky/graphql_template/-/tree/repository . The problem is that I am getting an error when I try to build it in the pipeline: Failed to read file .....src/web/Cargo.toml. I guess the problem has something to do with Cargo not being able to find the dependencies when the project uses workspaces in the main Cargo.toml, but I am a bit lost here.

You can find the .gitlab-ci.yml and the project itself in the URL I mentioned above. I would be really thankful if someone could tell me what is happening here.

Thanks a lot :wink:

Your project is not public. :neutral_face:

@AndreKR

Oops, my bad, thought it was public :sweat_smile:. Now it should allow you to access, thanks

The src/web/cargo.toml file name has a wrong case. You need to rename it to Cargo.toml (capitalized).

1 Like

wow... I feel ashamed now hahahaha. Thank you very much.

I still do not know why it worked locally and not in the pipeline, maybe because of the OS. Never thought the solution could be so simple :slight_smile:

I guess that's due to your local (case-insensitive) filesystem.

APFS, for example, comes in different flavors. My Mac reads both Cargo.toml and cargo.toml just fine. GitLab CI probably uses Linux runners with a case-sensitive filesystem by default.

yeah, that's the reason, I was using a mac to build it and everything worked perfectly there. Thanks for the explanation :wink: