Futures require #![feature(pin)]?


#1

I just added Futures to a project and now I get tons of compiler errors with the hint:

help: add #![feature(pin)] to the crate attributes to enable

However, I’m planning on using Futures on both my crates, crates that use my crates, and applications that use both of those…

Where should I add that annotation?


#2

Which version have you added? futures v0.1 is the wildely-used compatible one. Newer versions require unstable compiler.


#3

Tried changing to 0.1 and got this:

error: failed to select a version for the requirement `futures-preview = "^0.1"`
  candidate versions found which didn't match: 0.2.2

#4

oh nm - I see now looking at crates.io: futures = "0.1.25"