Error with rustup-init


#1

Hi everyone,

I’m having trouble running the rustup-init installer on my macbook air (Sierra 10.12.4 (16E195)).

I first tried running the curl https://sh.rustup.rs -sSf | sh automatic installer and got the error. I then manually downloaded the installer for my arch and ran it, getting the same error.
My last attempt has been to install rust through homebrew, clone the rustup source and build it using the command cargo run --release. After the build process it ran the installer and produced the same error.

All attempted installs were run with the evn RUST_BACKTRACE=1.

I’ve copied the error message from the last attempt (compiled from source).

Finished release [optimized] target(s) in 169.67 secs
 Running `target/release/rustup-init`

thread ‘main’ panicked at ‘assertion failed: (left == right) (left: 2, right: 1)’, src/rustup-cli/self_update.rs:495
stack backtrace:
1: 0x107c492fc - std::sys::imp::backtrace::tracing::imp::write::hd0934ba39adebbb8
2: 0x107c4faee - std::panicking::default_hook::{{closure}}::hb1bd81df62749d9a
3: 0x107c4f790 - std::panicking::default_hook::h7d23a7ef90ce63fe
4: 0x107c4ffa7 - std::panicking::rust_panic_with_hook::h382cf6fcd4ddab2e
5: 0x107c4fe54 - std::panicking::begin_panic::hcbf8c8f4707f29aa
6: 0x107c4fd72 - std::panicking::begin_panic_fmt::ha969e51ac26466ca
7: 0x107a513dd - rustup_init::self_update::install::hc1161dbd95035a22
8: 0x107a5e0fc - rustup_init::main::h407deb137ea2c4f9
9: 0x107c50e9a - __rust_maybe_catch_panic
10: 0x107c50376 - std::rt::lang_start::heeb14cb3e1434a24

Any help would be appreciated.

Thanks,

JamesB.


#2

See https://github.com/rust-lang-nursery/rustup.rs/issues/1034

Try running inside bash by executing bash in your terminal before the curl | sh install command.


#3

Thanks for you help. That worked!


#4

This is fixed now. Sorry for the hassle.