Embedded Rust on Pico - cannot use debug mode

While i tried to set everything up and running using the following template - GitHub - rp-rs/rp2040-project-template: A basic rp2040-hal project with blinky and rtt logging example code. With this you can quickly get started on a new rp2040 project

Got the error:
Running probe-run --chip RP2040 target/thumbv6m-none-eabi/debug/rp2040-project-template
Error: Failed to get information for AP ApAddress { dp: Multidrop(1002927), ap: 0 }

Need clarity on the issue and help me friends

Things to consider:

  • Check the all cables again. (Describing which cables are connected will help.)
  • Reread the probe-run documentation

(FWIW embedded rust is still on my bucket list)

Total shot in the dark:
I had the weirdest troubles with debugging/programming a nrf52840. Sometimes everything worked, sometimes nothing worked. Sometimes I could flash it.
The problems where caused by a faulty gnd connection. Took me way too many hours.
If you have a voltmeter check every connection from the board to the debug probe. If you don't have one it might be time changing this (was the only way I found the faulty gnd).

The error message is not very informative, there is an issue on it jlink: Unhelpful error message when multidrop is not supported · Issue #997 · probe-rs/probe-rs · GitHub

Which probe are you using? I've had some issues connecting to the pico using a DAP42.

1 Like

worked fine - after checking with existing pico - made both ground common

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.