Eclipse IDE Code Completion - libcore library missing?

I will start with oft-stated line - "I am new to Rust"! I am using the Eclipse IDE since it is familiar to me from other development efforts. All has gone well until I updated Rust this week. Code completion stopped working and I see the following error:

"Rust 'src' directory: Path C:\Users\mymachine\.rustup\toolchains\nightly-x86_64-pc-windows-msvc\lib\rustlib\src\rust does not contain 'libcore' directory."

I confirmed that this is the directory set in the Rust Preferences in Eclipse. The error message is correct - I do not see that directory in the specified path.

I scanned my Rust installation and cannot find a libcore directory. Is this a problem with the nightly build, did I do something wrong, or is an option setting wrong? I am not sure where to look, and searching the internet has not turned up this error. Anyone have some advice for me?

There were some recent changes in rust's own directory layout. Could you try switching to stable toolchain and see if this fixes the issue?

Or does Eclipse automatically picks nightly for some reason?

1 Like

Thanks matklad for the response. I only have the nightly installed right now (I think this is because I am experimenting with which requires the nightly and I just did a fresh install on a new machine, so went with what I needed). I used to run the stable release on my older machine and haven't done an install where I have both builds on the same machine. I will figure that out and attempt what you are suggesting.

matklad, your suggestion worked, though I ran into a new annoying problem while doing so (used rustup to install stable, received error message 'component miri not available for windows-msvc', read elsewhere I need to use --force to bypass components that are in nightly but not in stable).

Thanks again, but is this just a band-aid for now? If nightly is missing libcore now, does that mean it will eventually be missing in the stable build as well? How does this kind of problem get fixed in the Eclipse IDE where it is looking specifically for libcore?

(Remember, I'm new to how all this works together, kinda cool to be involved in the early phases, but also kinda pain when things don't mesh and you have to learn the underpinnings)

libcore is probably not missing, just moved.
Knowing nothing about the plug-in, I'd assume it'd have to be updated.

1 Like

Gilna, I thought the same thing at first. A scan for the libcore directory turned up empty on the nightly build, so I no longer think that is the case.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.