Diesel do not work on windows10

Hi all,
today, I tried to install diesel and it is quite so hard to make it work, the diesel version 1.4.5 and diesel_cli is also installed but there is no way to see something running with "diesel setup" or migration command. the environment is modified with correct path... what should I try for the next or which is able to replace the diesel .

hope to get good news from all of you... i'm new comer

In what way does it not work?

I follow the guideline on this site then I cannot make it work. I also download some projects which diesel is used but I have no more option or understanding to solve it...

http://diesel.rs/guides/getting-started/

You need to tell me in which way it failed. Was there an error message? I can't read your mind, nor can I see your screen.

2 Likes

luckily, I have no error to check ...

:laughing:

Are you sure that it is supposed to print anything? The tutorial just says it does something to the database and creates an empty directory.

1 Like

yes, you correct, it will connect to database and create a migration folder, I did not have those things and I hope to find out the reason ...

Did you look for changes in the IDE or in the file explorer? IDEs are supposed to make it easy, but directory changes are not their strong suit, from my experience.

i ran the code on powershell and I think it will not get control from IDE, the explorer also have no change. :slight_smile:

Try following the next step. If you encounter an error, paste it here.

thanks, it take one day, I will not try again...

The reason I asked you to run the next command after the setup is, because it's hard to be of help to you without any thrown errors we can work with. If you think the setup should say anything, regardless of whether it succeeds or fails (I think it should), I recommend creating an issue on the diesel repository.

Personally, I don't have any experience with diesel and I understand where your confusion comes from. However, if you ask for help and people are willing to help, it'd be nice if you didn't give up too quickly. We're also offering our free time to help and we try to not sound too harsh, but usually when it comes to basic questions the way of asking can be very direct, not out of disrespect, but for clarity's sake.

Sure you took a day, but the amount of work you put into getting it to work isn't clear from the information you provided us, so far. To be able to provide the best help possible, we do require a certain degree of information. There are a lot of crates out there and not everyone on the forum knows about every crate (in detail), so it's also a learning process for those going out their way to help you, if they aren't experts and I hope you bring a bit of patience with you for us, just like we do for you.

P.S.: Even if you stop pursuing the usage of diesel and try out something else, please don't shy away from asking for help, in the future. Perhaps, it's better to ask earlier rather than later, next time, so you don't have to waste as much time.

4 Likes

That looks like some of the required dependencies are not available at runtime. As far as I remember you need to have libpq in your path on windows. To be clear that's not a issue with diesel itself, but with your environment.
As a general strategy for such cases: Have a look at the application return code after running an application that does not do the expected thing. The return code will normally tell you what's wrong.

1 Like

thanks for your words, it is really friendly, it's so hard sometime and I have to jump out to cooldown :blush:

I got your support and I also got that error for missing the postgres library during the installation (cargo install --no-default-features --features 'postgres'), that was fixed with coping the missing lib file and dll to cargo lib, it is success for me. after that, I can type diesel setup but this command is not work for me... :slight_smile:

I do not use windows by myself, but as far as I remember windows requires that dll's from dependencies are in your PATH variable. If they are not the applications just "silently" fail to load. The exit code indicates that, but there is no other indication for the user. That is nothing the application can control, because that's operation system behavior.

1 Like