Cross on linux mint 21.2 fails with GLIBC_2.25' not found

Hi,

I try to crosscompile my old project on my fresh installed linux mint. But I get this error:

> cross build --release --target=armv7-unknown-linux-gnueabihf
info: downloading component 'rust-src'
info: installing component 'rust-src'
   Compiling untrusted v0.7.1
   Compiling libc v0.2.148
   Compiling tinyvec_macros v0.1.1
   Compiling ring v0.16.20
error: failed to run custom build command for `ring v0.16.20`

Caused by:
  process didn't exit successfully: `/target/release/build/ring-375dae82d7b314c6/build-script-build` (exit status: 1)
  --- stderr
  /target/release/build/ring-375dae82d7b314c6/build-script-build: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /target/release/build/ring-375dae82d7b314c6/build-script-build)
  /target/release/build/ring-375dae82d7b314c6/build-script-build: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /target/release/build/ring-375dae82d7b314c6/build-script-build)
warning: build failed, waiting for other jobs to finish...

Here some diag infos:

> rustup show
Default host: x86_64-unknown-linux-gnu
rustup home:  /home/woody/.rustup

installed targets for active toolchain
--------------------------------------

arm-unknown-linux-gnueabihf
armv7-unknown-linux-gnueabihf
x86_64-unknown-linux-gnu

active toolchain
----------------

stable-x86_64-unknown-linux-gnu (default)
rustc 1.72.1 (d5c2e9c34 2023-09-13)

> sudo apt-get install libc-dev
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Hinweis: »libc6-dev« wird an Stelle von »libc-dev« gewählt.
libc6-dev ist schon die neueste Version (2.35-0ubuntu3.3).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 5 nicht aktualisiert.

5 Month ago everything worked on my old ubuntu. Now I have no clue what to do to fix this problem.

Any help apprecciated,

Mark

1 Like

Do you have the build tools for that target installed? You probably need the package gcc-arm-linux-gnueabihf and libc6-dev-armhf-cross.

I thought with cross I don't need the build tools. Ok, but now I installed the tools but I see still the same error.

Looks like something weird is going on with the ring build script? You might want to ask the ring maintainers.

Some days and reboots later it works. No idea why.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.