Cargo test run on every save

I'm using lsp-mode, and have following configs:

(setq lsp-log-io nil
        lsp-rust-server 'rust-analyzer
        lsp-rust-analyzer-cargo-watch-enable nil  ;; set  "rust-analyzer.checkOnSave.enable": false
        lsp-diagnostic-package :none)

The test command look like this, how can I disable this?

cargo test --no-run --lib --message-format=json

Answer this question three months later by myself.

It's flycheck-rust to be blamed. No cargo instance is running after disable it in my emacs.d.

1 Like