Cargo outdated -- certificate problem

Using cargo outdated I get

error: failed to download from `https://crates.io/api/v1/crates/block-buffer/0.10.1/download`

Caused by:
  [60] SSL peer certificate or SSH remote key was not OK (SSL certificate problem: unable to get local issuer certificate)

Not sure where to report.

It looks like this has already been reported on the cargo issue tracker:

Do any of the suggestions in that ticket help?

I tried renaming /etc/ssl/certs/ca-certificates.crt which didn't help. I should mention that cargo build works just fine. Only cargo outdated gives above error.

Nevertheless, it must be a local problem as I tried on another Ubuntu system of mine, and there also cargo outdated works fine.

Now, I found some time to do some more testing.

First, I should add that I have installed rust aso. in ~/.cargo using rustup.

I created a new user and installed cargo using rustup, and here cargo outdated works just fine. My guess is that something in ~/.cargo is causing the cargo outdated error.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.